Intermittent issues accessing Spot AI dashboard features for some users

Incident Report for Spot AI

Resolved

All lingering effects of the outage should now be resolved. Please reach out to us if you continue to experience issues with the system
Posted Oct 20, 2025 - 18:40 PDT

Update

We are continuing to work with our service providers to restore full functionality on our dashboard. We are still experiencing frequent access issues with the dashboard.
Posted Oct 20, 2025 - 13:43 PDT

Identified

We have identified the problem to be related to downstream service providers resulting from the AWS outage reported today. We are working to restore full functionality as soon as possible
Posted Oct 20, 2025 - 11:13 PDT
This incident affected: Spot Platform.