Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 28, 2025 - 21:00 PDT
Scheduled
We will be performing a routine security configuration update on the Spot AI cloud dashboard and IVR systems. There may be a slight increase in error rates while accessing the platform, but there should not be a significant impact to functionality. This does not impact recording.
Posted Oct 28, 2025 - 16:24 PDT
This scheduled maintenance affected: Spot Platform.